Debian, Wi-Fi i BenQ R56

Co zrobić, żeby działało Wi-fi. Pierwotnie był to post na forum Debiana.

Co siedzi w BenQ R56:

chavez@debian:~$ lsusb
Bus 001 Device 003: ID 18e8:6229 Qcom RT2573
Bus 001 Device 002: ID 04f2:b024 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 15ca:00c3 Textech International Ltd. Mini Optical Mouse

Wujek google i kombinowanie wykazały, ze karta sieciowa Qcom-u oparta jest o chipset firmy Ralink. Glebsza analiza wykazała, ze w systemie są już załadowane odpowiednie sterowniki. Problem pozostaje wiec tylko w podpięciu tego do routera.

Dodanie do pliku /etc/network/interface wpisu o automatycznym podnoszeniu wlan0 niewiele dało. Skorzystałem także z wpa_gui w celu podłączenia, niestety program przywiesza się podczas łączenia (opcja skanowania pokazuje dostępne sieci bezprzewodowe).

Znalazłem także narzędzie dedykowane do tego typu kart rutilt – teoretycznie pokazuje, że nawiązano połączenie, jednak net nie działa.

I się jednak udało.

Do pliku /etc/network/interfaces należy dopisać:
Kod:
# wifi
allow-hotplug wlan0
iface wlan0 inet dhcp

Zainstalować program wifi-radar, warto chyba także mieć pakiety związane z wpa, jeśli stosuje się to szyfrowanie. Po odpaleniu wifi-radar wypełnić opcje, w driver podając np.: wext

Przy czym warto także mieć zainstalowany program rutilt – można go ustawić w trayu do monitorowania połączenia.

Tagi: